Touch Version
logo
Symbian Games | Symbian Software | Android | JAVA
Version: S60 5th Edition (change)
Fixing Certificate Errors On Symbian Mobile Phones

If you use an Symbian S60 3rd edition based mobile phone (Nokia N-Series phones like N73, N95, N80, N91, N80 and E-Series phones use Symbian S60v3 as OS) you must have encountered the very common certificate errors like 'Certificate Expired' or 'Certificate Error. Contact Application Supplier' while installing themes or softwares on your phone.

symbian expired certificate error

The errors are caused because of the security measures introduced into the new version of Symbian Series 60 mobile operating system disallowing installation of old applications and invalid certificates, however bypassing this security feature and fixing these certificate errors to install themes and softwares is very easy, simply follow the instructions below:

1- Open you mobile main Menu.
2- Navigate to Settings -> General -> Date and time
3- Now change the year back to 2010 or 2009.
fix symbian expired certificate error
4- Now install the application.
5- Don't forget to change date back to original.

If the above does not solve the problem goto Application Manager > Options > Settings and set "Online Certificate check" = Off and Software Installation = All.

Note: If you own an older phone you might receive the following error:

"Installation security error. Unable to install"

To solve this error and install application/Theme navigate to Tools -> Options -> Setting -> Software Installation and change setting to On.

Symbian Games
Touch Version
MAIN MENU
Touch Version
toptop

Sponsored Links:

Touch Version